Memory card issues/corrupt files


(Bethany Plonski) #1

Hello,
Not sure if this is a common thing, but just thought I’d ask to see if anyone has had a similar experience. I’m using a Nikon D70, and ever since I started shooting in raw format, I’ve had sporadic issues with the image files being corrupt or unreadable. Sometimes I only lose a few images from the batch, and every now and then the entire batch is ruined.

I’m not sure if the problem is the camera, the card, or how I am uploading and deleting files.

I tried the most obvious fix first - buying a new card. That worked for about a week before the same problem started happening again.

Then I found a Nikon forum where someone said that deleting image files through the camera’s delete function (rather than deleting through the computer) could be the problem. I followed their advice, and at first it did help me reduce the number of photos lost per shoot. This weekend though, I took over 200 photos and was only able to salvage about 30 of them. There doesn’t seem to be any pattern to which files are corrupt and which are usable.

I do format the card in camera each time I start shooting, and I have tried uploading the files through a card reader and directly from camera to USB with the same results. If it matters, the card I am using is a San Disk Compact Flash Ultra 16 GB/50MB/s.

I’d love to hear if anyone has had a similar problem or advice about how I can tell for sure if the problem is with the camera or the card.

Thank you for reading :slight_smile:
Bethany


(Berckmans Peter) #2

Had one time a small issue with pics in raw. But after deleting it was fine . Maybe a faster card can help. You use the 50M/s,maybe try the 90. It was reccommended to me and works fine.


(Ram Ya) #3

I was going to recommend formatting the card only through camera but I see you are already doing it.

I have never had issues with my cards so far. It is strange that this is happening in a brand new card as well. You mentioned that you delete photos from camera’s delete function, do you only get this issue for the batches where you have deleted image from camera’s delete function?


(Benjamin Theyr) #4

Formatting the card would be a good idea but if there’s images on the card, you wouldn’t want to lose them. The best options if formating doesn’t help, then check the camera firmware update.


(Russell Smith) #5

I have had it happen one time and it was a few images. I also have had it happen where the card reader went stupid and did not “see” any images on the card. I swapped out the card reader and it worked fine .
Personally I do not delete images from the card through the camera . I just do not import those images that are pooo to lightroom. I have read that it is a bad idea and I do not want to test that theroy out to see if it is true. I do carry a few extra memory cards with me . 1 in the camera strap I have and I have one in my wallet ( I have not checked the camera prior to a trip and multiple times I have forgotten the card in the computer) . I also do not format the card in the computer I format the card in the camera. I would be curious to if it is the same card giving you the issue or if the same card is doing it multiple times. That is the point I would toss the card. One other thought . Is there a magnet or magnetic source near the cards? That can and will corrupt the cards (unless it is one that is designed to shield from magnets) .


(Benjamin Theyr) #6

Magnetic or oxidized cards for sure. Typical cameras of today are not completely water sealed so one can expect issues like this if any moisture was to enter into the card reader chamber.


(Bethany Plonski) #7

Thank you so much to everyone for chiming in! Your responses made me think of a few other things.

  1. I stopped deleting in camera a few weeks ago, and at first I was convinced that was what had been causing the problem. When I started deleting through the computer instead, I didn’t lose any images for about a week, but now I am losing images even when I format in camera and delete through the card reader or computer.

  2. Also, two different things will happen with the corrupt files, and it depends what card I’m using. With one card (the newer one), I see the files but can’t open them at all (just an error message). With the older card, some of the files can be opened, but they are just a bunch of colored bars and pixels.

  3. This weekend when I lost the most images, I was connecting directly through USB and it seemed like the camera was crapping out mid-connection. I could see all the files on the card, but when I tried to open them or import them into Lightroom, I got an error message that said the device wasn’t responding. This weekend was the first time that ever happened in conjunction with the corrupt files.

  4. I have never done a firmware update, but this is an older camera that I got from someone who hadn’t used it regularly for a few years. I think it probably needs the update. But after reading the instructions for that today, I am afraid to try it because of how the camera stopped responding when it was connected last time. Nikon’s instructions say if the camera loses power or freezes up during the updates, it can cause even more problems.

I’m pretty sure I haven’t been around anything magnetic recently, but that’s good to know for future reference!

I found a local camera shop with good reviews today and left a message with them to see if they can help me with the firmware update. If that doesn’t go well, I might be in the market for a newer camera soon. I also ordered a new and faster card to see if that helps.

Thank you again for your help. I really appreciate it!


(Benjamin Theyr) #8

San Disk Compact Flash Ultra 16 GB/50MB/s.

Just an observation, please check your owners manual for “Supported SD Card” as I do not see the card you’re currently using within the owners manual list:

Approved Memory Card page 191

Follow Up:

Something came to mind this morning, if I’m not mistaken, check the setting on your camera for a “Timed Delete Feature” setting as if you’ve updated your firmware, this could have been reset or you could have inadvertently press an option which auto deletes images.


(Abigail Gossage) #9

The D70 is a great camera but in digital terms it is old. It may well be that it cannot use a larger card as the above post suggests. Try using smaller cards.


(Bethany Plonski) #10

Thank you! Both good observations. It’s been a challenge trying to find an approved card because everything tends to be larger and faster now. One of the drawbacks of using an older model, unfortunately.


(Russell Smith) #11

I have an old Rebel xs . I understand the challenge of trying to find sd cards for it . Last time I took it as my main body I left the cards that would work with it. I found one at an older small drug store of all places.


(Bethany Plonski) #12

Yep, most of the ones I found online were used, which seemed risky. I took the camera in the shop today and while the repairman tested it, it gave a CHA error, and he thought there was a bent or dirty pin. We cleaned the pins with alcohol and tried three different cards, which all worked successfully after the cleaning. He did recommend that I just upgrade to a newer body if the problem occurs again because it seems like a waste of money to put new pins in such an old camera at this point.